Author Topic: LG 50PK590 WILL TURN ON BUT NO SOUND NO PIC  (Read 1565 times)

0 Members and 1 Guest are viewing this topic.

samisat

  • Full Member
  • ***
  • Posts: 85
    • Email
LG 50PK590 WILL TURN ON BUT NO SOUND NO PIC
« on: June 25, 2016,12:52:25 »
Hi guys I got this plasma in which when you press the power button ,will comes up but only got back light,no sound ,no picture.I checked power supply and there is not any O/C components.any help Please?
Thanks for your time.
sami

Mulja tv repair portal

LG 50PK590 WILL TURN ON BUT NO SOUND NO PIC
« on: June 25, 2016,12:52:25 »

downunder

  • Hero Member
  • *****
  • Posts: 938
Re: LG 50PK590 WILL TURN ON BUT NO SOUND NO PIC
« Reply #1 on: June 26, 2016,05:08:43 »

Hi sami,

Might be a good idea to run the Auto Gen on the control board, test points R51, R52, and set if test patterns are displayed.

Bruce

samisat

  • Full Member
  • ***
  • Posts: 85
    • Email
Re: LG 50PK590 WILL TURN ON BUT NO SOUND NO PIC
« Reply #2 on: July 07, 2016,05:45:51 »
Thanks mate unfortunately I haven't got GAN however i got faulty lamp in screen as going to light up,  :c017: then goes off.
  http://www.tv.quuq.org/forum/Smileys/default/c017.gif

Mulja tv repair portal

Re: LG 50PK590 WILL TURN ON BUT NO SOUND NO PIC
« Reply #2 on: July 07, 2016,05:45:51 »

downunder

  • Hero Member
  • *****
  • Posts: 938
Re: LG 50PK590 WILL TURN ON BUT NO SOUND NO PIC
« Reply #3 on: July 08, 2016,03:40:22 »

GAN? what's that, geeks and nerds?

Auto Gen is an inbuilt pattern generator, activated by disconnecting Control board from Main, shorting out the test holes at R51/R52 on the control board, then switching the tv on. If PSU and scan circuits are working, patterns are generated on the screen. Conclusion - main board is faulty.

And you haven't got a faulty lamp in the screen - it's a plasma tv - they don't have lamps.

Bruce

Turnip

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3365
    • Email
Re: LG 50PK590 WILL TURN ON BUT NO SOUND NO PIC
« Reply #4 on: October 18, 2018,10:28:48 »
Hi folks,
Have one in where it works normally for several days then cuts to S/by Red Led glowing and won't turn on again 'till the next day maybe where it works for some while then cuts again, but it doesn't noticeably click (Favourite issue)

Found some stuff -

For various no go faults R927 & R929(20R 5W)
IC301(3BR1565JF   6 pin chopper) & D304(SR104)
IC701(F4316MSF17   28 pin chip) 
R103  R104(both 240k)  R105  R106(both 150k)  R107(100k) One series string
R108  R109  R110  R111(all 680k)  R112(620k)  R113(560k) Other series string, all SMD.

Resistor strings OK - (Checked every one with one end disconnected)  Tend to suspect IC301 though it hasn't popped D304.

Wonder if anyone has thoughts about a 'non click' situation - Thanks - Chris.

downunder

  • Hero Member
  • *****
  • Posts: 938
Re: LG 50PK590 WILL TURN ON BUT NO SOUND NO PIC
« Reply #5 on: October 19, 2018,03:40:38 »

Hi Chris,

IC701 has been known to cause int power problem. May be a place to start.                     Bruce

Mulja tv repair portal

Re: LG 50PK590 WILL TURN ON BUT NO SOUND NO PIC
« Reply #5 on: October 19, 2018,03:40:38 »

Turnip

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3365
    • Email
Re: LG 50PK590 WILL TURN ON BUT NO SOUND NO PIC
« Reply #6 on: October 19, 2018,12:24:06 »
Thanks Bruce, have one on order,

Just curious a folks always say the set clicks but mine doesn't.

Another chap mentioned that those resistor strings are dubious although maybe read ok - Also that the glue securing the SMD resistors can become suspect - Met that before, mostly on early Sammies - Guess change the lot - Chris.

 

Powered by EzPortal