Author Topic: Technics SU-V470 - Sound only one channel.  (Read 196 times)

0 Members and 1 Guest are viewing this topic.

Turnip

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3364
    • Email
Technics SU-V470 - Sound only one channel.
« on: June 26, 2018,13:25:37 »
Hi folks, got one in where on headphones it's OK but on speakers it's just one channel. Downloaded the manual from ElectroTanya - Great site, but wonder if it's just liable to be the output module, as awful expensive - Chris.

Mulja tv repair portal

Technics SU-V470 - Sound only one channel.
« on: June 26, 2018,13:25:37 »

Keith

  • Hero Member
  • *****
  • Posts: 373
Re: Technics SU-V470 - Sound only one channel.
« Reply #1 on: June 27, 2018,05:31:31 »
Hi Chris,

From my failing memory, I think the headphones use the output from the power amp ICs, so i f you have audio from the headphones, the power amp modules should be OK.

Keith

jordan

  • Hero Member
  • *****
  • Posts: 849
Re: Technics SU-V470 - Sound only one channel.
« Reply #2 on: June 27, 2018,10:55:49 »
Resorder output and pre-ampflier stage
Greeting from Slovenia
Jordan Čebron

Mulja tv repair portal

Re: Technics SU-V470 - Sound only one channel.
« Reply #2 on: June 27, 2018,10:55:49 »

Turnip

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3364
    • Email
Re: Technics SU-V470 - Sound only one channel.
« Reply #3 on: June 27, 2018,11:49:32 »
Many thanks folks,

In the event it was just dubious contacts on the 'Tone control - In or out' switch, where one channel nearly vanished. Didn't care to take it all apart as would have taken all day, so gave it a squirt from the front where it did the biz. Did the same with the balance pot as a bit 'iffy.

Normally like to take things apart to sort, but this Technics isn't serviceman friendly - Chris.

 

Powered by EzPortal
download