Author Topic: Panasonic TX-P42S20B Control issue  (Read 264 times)

0 Members and 1 Guest are viewing this topic.

Turnip

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3390
    • Email
Panasonic TX-P42S20B Control issue
« on: July 21, 2018,07:44:16 »
Hi folks,

Got one reported sometimes no go. Did a factory reset, seemed OK 'till going around the menu, response slowed down and set cut both sound and picture but with a steady Green Led. Couldn't recover with RCU but using the s/by switch set came on again but with the same issue - any thoughts ? - Chris.

Mulja tv repair portal

Panasonic TX-P42S20B Control issue
« on: July 21, 2018,07:44:16 »

downunder

  • Hero Member
  • *****
  • Posts: 944
Re: Panasonic TX-P42S20B Control issue
« Reply #1 on: July 22, 2018,02:32:05 »

Hi Chris,

All Panasonics I've done that have had green LED on but otherwise apparently lifeless have hat a faulty A board (Main or SSB depending on your school of thought). Could check SC board earthing but not likely to be causing your problem.

Could try a restore to shipping conditions when it's actually operating. Press/hold down arrow [v] on the control panel then press Menu on the remote.
The Self Check screen will appear, then simply turn off at the mains. A retune will be necessary when you power it back on.

Bruce

Turnip

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3390
    • Email
Re: Panasonic TX-P42S20B Control issue
« Reply #2 on: July 22, 2018,11:43:10 »
Thanks Bruce,

Guess SSB as set OK when cold but after a few minutes OSG slows down giving the Green led, though suspect display bits are working OK, as vague illumination present.

Tried 'factory reset' from main menu, but will try your suggested option. Had a look on Ebay, and SSB is the only expensive panel - Often seems a guide to the issue - Chris.

Tried 'Self Check' and got 'Self Check' OSG top left, but nothing else 'till I turned set off and re-tuned.
« Last Edit: July 23, 2018,11:23:35 by Turnip »

Mulja tv repair portal

Re: Panasonic TX-P42S20B Control issue
« Reply #2 on: July 22, 2018,11:43:10 »

astracat

  • Hero Member
  • *****
  • Posts: 264
    • Email
Re: Panasonic TX-P42S20B Control issue
« Reply #3 on: July 25, 2018,16:25:21 »
hi turnip
this sounds like its had a bad update suggest re download software and replace with your downloaded version hopefully this might cure it,note have had one with a dodgy regulator going low in output sorry cannot remember the regulater but think it was a 3v output type and it dropped in value to about 1.5v
regards
astracat

 

Powered by EzPortal
download