Author Topic: Goldstar crt TV 25" installed in a arcade cabinet - weird picture  (Read 104 times)

0 Members and 1 Guest are viewing this topic.

repetto74

  • Newbie
  • *
  • Posts: 2
    • Email
Hi Guys,

I am desperate to obtain a decent picture with the 15khz CRT TV I have installed in my cab (my previous arcade electronics has gone bad and the flyback is no more available). It is a Goldstar CBT-2570X 25" TV with scart inputs so I purchased a quality VGA RGB to scart cable with +12v and +5v molex connector for the A/V commutation and RGB switch.

Unfortunately I cannot get past this video quality where the image looks dim and some weird horizontal lighter coloured bars appears where text is displayed. :73:

What I am sure of is that the cable is not the cause. I have tried to connect a DVD player with a standard scart cable and I do have the same issue when displaying the DVD menu. What this can be? There are a lot of pots on the TV chassis I can adjust and also the focus and brightness on the flyback. Is that a problem with the sync?  :dubbio: Where can I tweak before thinking this is a video circuit fault? Enclosed also the block diagram of this electronic. (chassis PC-12A)

https://ibb.co/JyYSZSP
https://ibb.co/r3DJB19
https://ibb.co/vvDSK75
https://ibb.co/zQ1hm61
https://ibb.co/GVfnfPf
« Last Edit: May 09, 2019,09:56:49 by repetto74 »

Mulja tv repair portal


astracat

  • Hero Member
  • *****
  • Posts: 284
    • Email
hi
this looks like a scan refresh problem ,its possibly running too slow at 15khz .not much twiddling of the pots will cure it as the pots wont adjust far enough it needs to refresh its scan about 50/60 khz
regards
astracat

repetto74

  • Newbie
  • *
  • Posts: 2
    • Email
The PCB has pots for the Phase, Trap and Delay adjustments. Could one of these make a difference? :dubbio:

Mulja tv repair portal


astracat

  • Hero Member
  • *****
  • Posts: 284
    • Email
hi
those pots not the problem ,would wind down the height to see if looks better first if so check interlace scan circuit .the clue is the lines in the writing
caps in the vert frame output may need replacement

regards
astracat

 

Powered by EzPortal