Author Topic: Samsung plasma ps50c96hd picture problem, flat color, no uniform color, blur  (Read 363 times)

0 Members and 2 Guests are viewing this topic.

chris333j

  • Jr. Member
  • **
  • Posts: 11
    • Email
Hi, I have a plama samsung (ps50c96hd) and the picture is very bad.
I'm new in this forum so i edit this post, sorry for that...
The picture :


With no signal there are grey point :


I have control all the voltage (Vs, Vsc, Va, Ve...) all is good.

On the Z card (on right) i just replace a bad capacitor (25v 680mf) but no effect.

I have change the t-con module but no effect...

If you can help me plz  :03: :03: :03:

Mulja tv repair portal


chris333j

  • Jr. Member
  • **
  • Posts: 11
    • Email
I have change the t-con (control) and the power-card but no effect.
The problem :
https://youtu.be/GxG9rA_kXFw
Thanks a lot for any idea...

downunder

  • Hero Member
  • *****
  • Posts: 1044

Fairly certain you have a faulty X-main board, based on the murky swirling background to the picture. Ohms check all the FETs etc attached to heatsinks on the x-main in case one is shorted.                          Bruce

Mulja tv repair portal


chris333j

  • Jr. Member
  • **
  • Posts: 11
    • Email
thanks for your answer Downunder.
Could I check the FETs directly on the card or must he desoldering ?


downunder

  • Hero Member
  • *****
  • Posts: 1044

Just check them in situ. If you get an unusually low reading, then maybe remove, or snip two of the legs, to recheck. If ok, then you should be able to resolder the severed legs.

I'll upload the service manual to the forum. Page 4-14 seems relevant.

chris333j

  • Jr. Member
  • **
  • Posts: 11
    • Email
I check immediatly with a multimeter in diode test mod ?
Thanks a lot

Mulja tv repair portal


chris333j

  • Jr. Member
  • **
  • Posts: 11
    • Email
In situ with my eye all seem to be perfect.
With my multimeter I don't know how check them.

downunder

  • Hero Member
  • *****
  • Posts: 1044

Yeah, you won't see much on the surface unless its blown up.

Put "how do I check Field Effect Transistors" in your search engine.                                  Bruce

chris333j

  • Jr. Member
  • **
  • Posts: 11
    • Email
Good evening, I reconnected the television without the x-main control card and ... the image remains exactly the same, there is only the sound that has disappeared. It's strange, is not it? Thank you

downunder

  • Hero Member
  • *****
  • Posts: 1044

Not strange at all. A plasma is capable of generating  a picture without the X-main. It's just that its a yukky picture like yours. The fact that it's the same with or without the x-main could be trying to tell you something.        Bruce

chris333j

  • Jr. Member
  • **
  • Posts: 11
    • Email
Change the x-main ? Repair the Sets or condensator ?

downunder

  • Hero Member
  • *****
  • Posts: 1044

Personally I'd replace it. Not likely to be available new, so check flea-bay.

chris333j

  • Jr. Member
  • **
  • Posts: 11
    • Email
X-main buy... reception 6 days. Should I check the Sets or condensator in first ?

downunder

  • Hero Member
  • *****
  • Posts: 1044

Not sure what you mean by that last remark.

chris333j

  • Jr. Member
  • **
  • Posts: 11
    • Email
I have check all the condo : 5 are ok (150uF) and 2 have 140uF... i thing no problem about it ?!?

 

Powered by EzPortal