Author Topic: Hitachi 42DP6600A Main Board  (Read 2393 times)

0 Members and 1 Guest are viewing this topic.

Sn0wBall

  • Newbie
  • *
  • Posts: 4
    • Email
Hitachi 42DP6600A Main Board
« on: March 30, 2009,11:27:44 »
Hi the display used to be fine but recently it has trouble displaying anything above 960 x 600 on pc and 720 on the xbox somtimes it even refuses to display those, it would ghost some of the image and disply random horizontal white lines but if you where to persivier it would display correctly after a while. Recently however after power up it displays a box of "snow" in the centre of the screen i am unable to see menus or inputs when like this but after some time of source switching and pip pressing and othrer random buttons i can get it to display a source but volume and menu OSD is pixelated text is snow. Its like the menu program is broken any suggestions im thinking main board i would consider getting repaired if anyone is confident they could resoulve the issue or if you have spares  :thumbup:

Thanks, Leigh
« Last Edit: March 31, 2009,17:24:42 by Sn0wBall »

Mulja tv repair portal

Hitachi 42DP6600A Main Board
« on: March 30, 2009,11:27:44 »

Sn0wBall

  • Newbie
  • *
  • Posts: 4
    • Email
Re: Hitachi 42DP6600A Main Board
« Reply #1 on: March 31, 2009,17:27:02 »
Today i was not able to get it working i had to warm the boards with a hair dryer before it would display properly

Mulja tv repair portal

Re: Hitachi 42DP6600A Main Board
« Reply #1 on: March 31, 2009,17:27:02 »

 

Powered by EzPortal
download
download
download